July 2011

Support for PHP 5.3 in RHEL 5 via new php53-mapi RPM package

July 29, 2011 by Robert Scheck   Comments (0)

, , ,

Red Hat introduced with with Red Hat Enterprise Linux 5.6 a new PHP version for users, which whish to migrate to a more current PHP release. This new version was packaged as "php53" and replaces the regular "php" (PHP 5.1.x) if the user chooses to migrate.
Unfortunately, PHP 5.1 and PHP 5.3 are ABI incompatible, that means that PHP modules that were compiled for PHP 5.1 can not be run using PHP 5.3. Every PHP module that shall work with PHP 5.3 needs to be recompiled from source.
What does... Read full post